Bug Report (and issues) version 30c*

Activity Forums Mud and Blood 3 Bugs and Technical Help Bug Report (and issues) version 30c*

This topic contains 28 replies, has 13 voices, and was last updated by  Lance 3 months ago.

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #7468

    Lance
    Moderator

    Thanks for the report. Someone else reported the same thing just a few days ago on the Discord.
    Question; Are you sure that the game fully loaded before you started it?
    Are your game save files safe? bz Does the game always save properly?
    Newest Flash Player? info; Adobe made a big patch for Flash lately that tremendously improved it.

    #7469

    Ronald McDad
    Participant

    Yes, my game was fully loaded and safe. I had just finished a previous run where i had taken 2 days to get back on schedule. However, when i tried starting this new deployment, firefox gave me a message “a script has stopped running on this page” and when i clicked stop, it loaded into what you see there in the screenshot. I’m not sure if this was a simple glitch on flash’s end (for the record i believe it’s fully updated since i have it on auto-update) or firefox not agreeing with the amount of tabs i had open.

    #7470

    Lance
    Moderator

    I use Fierfox myself and have noticed that when other tabs are open with sites containing video stuff like you-tube then it can happen that the game (Flash) bugs out.
    TIP: Manually check to see if you have the actual new Flash player.
    https://get.adobe.com/de/flashplayer/otherversions/
    Link may be in the wrong language for you.
    Bigger Tip; When playing Flash intense games like MNB3 or Recon it is best to not have any other tabs open.
    Since I follow this rule my Flash games have never bugged out since the last Flash update.

    #7582

    Ronald McDad
    Participant

    I’d like to put my two cents in and report some of the following bugs I’ve found while playing.

    Currently on D-day 48+, ahead of schedule by 1+ days.

    -Dead/alive Germans tend to move after they’ve already been downed. Basically, they have the downed animation yet still move statically and fire, then they return back to normal position.

    -After I reached Outskirts of St. lo, the Intel page kept flashing rapidly making it unreadable, not sure if this is a bug or something that isn’t implemented yet.

    -Weapons from crates always display the wrong name, usually just saying “M1 Thompson” even though it would be a browning or shotgun.

    -Enemy weapon crates don’t show the name of the weapon, nor do they show what it does.

    -Medic can self revive himself using syringe ability.

    -The Sdkfz 251 remains and still fires/drops troops even after it’s destroyed. Usually have to clear particle effect to rid it.

    -TNT, mortars, and artillery seem to disappear if you spam the particle effect icon.

    -I can’t seem to rank up past “colonel” in the ranks due to XP not being delivered to my profile.

    -Pinned units usually stay there for long periods of time, sometimes forever, and i have to kill them off to advance.

    -Radioman calls occasionally dont through, even if not under fire or near enemies.

    That’s all i have to report for now. This game still has a long way to go, but i hope it improves and i have helped with that.

    ~Cheers

    #7583

    Ronald McDad
    Participant

    Another issue i seem to have found is MG gunners (german gunners) seem to freeze up whenever you pause during their firing animation.

    #7628

    Lance
    Moderator

    23.04.18 Community Challenge. >> Medics Only. Ribbon gets awarded but in the Challenge Ribbon page there is no description when hovering over the ribbon. No hand either so I assume that there is nothing there at all asides the ribbon image.

    #7635

    Lance
    Moderator

    Re-posted here for Will who created 2 new new bug report topics (duplicates) despite the fact that there still is one for ver. 30* and therefore I deleted both.
    Will wrote:
    In the game on the engineer the rocket launcher action thing has no color and if you hover over it it just says ??? and some times when I shoot it sometimes it will just turn my cursor to the missile and not shoot and if I click again it says that I already used it.

    Lance; Old issue that has been addressed multiple times.

    #7645

    TANkyMEow
    Participant

    Idk if this some sort of bug…but. I played a recent game, and I met my first halftrack. It kept coming straight in a predictable manner, so I placed a minefield in its path. The first 2 mines exploded…but, surprisingly enough, the thing didn’t get destroyed o_o ….ok, I thought to myself…maybe it didn’t destroy it, but perhaps maybe it caused a mobility kill. I didn’t see any sort of suspension damage or anything, but I didn’t see it move any further towards my guys.

    So, the presumably immobilized halftrack was very near to the “magic forest” that my guys were hiding behind. So, I was like “ok, this will be ez”…but in reality no…attempt #2: Used two rifle grenades to blow it up…nuthing o__o ?? attempt #3: Used two AT-rockets…still nuthin o___O ??? attempt #4: Called in arty…guess what? All 5 arty shells landed on the bull’s eye, right EXACTLY ON TOP OF THE halftrack…500% accuracy…whoever directed that fire mission should’ve gotten a medal………..but when the smoke cleared O________O ?????? NNNNNNAAAAANNNNNNIIIII???!?!?!?!?!? The damn thing is still alive….WWWWWWTTTTFFFF???!???

    attempt #5: This last one was the funniest, because I moved my rifle guy very close to the halftrack to throw a hand gernade. Remember how I said that the halftrack was…”presumably” immobilized by the explosion from the first 2 mines?….well…just as my guy was getting into gernade range, the halftrack moved backwards. At the same time that it was retreating, it shat out its infantry section….ALL OF THEM!!!! Apparently, 2 rifle gernades (+) 2 rockets (+) five 155mm shells aren’t detrimental to the health of the ubermen panzergrenadiers (canned like tuna in an open-top APC) of the vaterlande….well, with the exception of the last land mine, which got triggered by one of the disembarking panzergrenadier…which killed all of them. 1 min later, the halftrack retreated off the map happily singing “alte kameraden”, while only giving 3 shits, schnapps, sausage, and more schnapps.

    A few minutes later, after this impossibly derp moment, I had another surprise…apparently, the shells I threw at that stubborn half track didn’t go into a black hole…no, there’s a more plausible reason. It turns out that sonna of a beech halftrack ate my shells, regurgitated it, and shat it out as landmines (I know halftracks can’t lay mines, but I would like to think this derpy one did) as it was shitting, and giggling back to whatever mother made it. DO YOU KNOW WHO HAD TO STEP IN DAT SHET???!?!?!?!!?!???!?!? MEEEEE!!!!! IT WAAAAAASSSSSS MEEEEEEEEEEE!!!!!!!!!!!!! I fffing lost 2 guys (…and it fffing HAD to be my two best units, my medic, and radioman)

    After that I quit the game, and asking myself if that rly happened…and other life questions lol 😛

    I wish I could’ve recorded this, but I didn’t have the hindsight to do it…but if I did…man, that would’ve been the weirdest urb moment in history :/

    #7646

    Lance
    Moderator

    Impressive bug report. Really impressive. :))
    Love that whole story a lot and actually read it trice for the fun of it.
    Enemy Half Track not reacting properly to damage was and is an issue indeed.
    I have had that a few times too. Sometimes the HT just disappears when killed and sometimes it simply freezes into place.
    Current Remedy; >> After you “may” have destroyed it but it still functions simply hit the ! to clear it away. Usually works.

    Towards the issue with the Bazooka not firing. I have a hunch. It may be the when firing your Engineer is actually out of range.
    This can happen when you select the bazooka, aim at the target and then hit fire BUT the soldier is moving backwards that the game then checks to see if the skill in in range and then notices that it is not and cancels the shot.
    Thereby also resetting the skill timer.

    #7653

    TANkyMEow
    Participant

    Yeah I tried the “!” button, but the halftrack was still on the screen, and retreating. IDK what’s going on :/

    #7771

    HIROBOY
    Participant

    Need help, anyone ,i got engineer level max and why does he never spot mines other than walk on it, how does engineer spot mines? its the deadliest enemy in this game

    • This reply was modified 5 months ago by  HIROBOY.
    #7775

    Tyrud
    Moderator

    You’re not wrong about the lethality (and randomness) of the mines in this game. Unfortunately, the current version of the game does not have mine spotting coded into the game. As a matter of fact, the game never has with the closest thing being that all mines were simply visible regardless of an engineer’s presence or level. That version of the game, however, is not currently up. So mines are just a sad fact of life that must be dealt with by occasionally losing people to them…

    A good report, nonetheless and a reminder that fixing that should be high on the priority list for any upcoming versions of the game.

    #8004

    Rezz
    Participant

    https://gyazo.com/cac0a7f84a56a4cc0e82762964edd6dd So I broke the intel its flashing D-day to Vire intel prompts, i bet if you freeze frame it you can get some pic for the wiki

    • This reply was modified 3 months ago by  Rezz.
    #8007

    Lance
    Moderator

    No bug and no breaking the game somehow.
    After Vire there is simply no Intel page implemented so the game flashed through all other available ones.
    Game simply needs updating. 😉

Viewing 14 posts - 16 through 29 (of 29 total)

You must be logged in to reply to this topic.

Skip to toolbar